Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, Yandex, DotBot

Members: 0
Guests: 12
Stats
Files
Topics
Posts
Members
Newest Member
481
3,739
19,386
619
Alexander
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » bug?
Forum Rules | Mark all | Recent Posts

bug?
< Newer Topic :: Older Topic > mob exp not loading properly

Pages:<< prev 1 next >>
Post is unread #1 Jul 11, 2004, 9:05 pm   Last edited Nov 18, 2007, 4:41 pm by Samson
Go to the top of the page
Go to the bottom of the page

ayla

GroupMembers
Posts8
JoinedJun 28, 2004

Found this while I was trying to figure out what was up with my mobs' exp not saving. In db.c in the load_mobiles function, the exp is not being loaded up properly, which causes the mud to autocalculate exp upon the next reboot, even if you've changed it online. If you're like me and find this annoying, change this
          pMobIndex->alignment          = x1;
          pMobIndex->gold                       = x2;
          pMobIndex->height             = x4;
          pMobIndex->weight             = x5;
          pMobIndex->max_move           = x6;
          pMobIndex->max_mana           = x7;

to this
          pMobIndex->alignment          = x1;
          pMobIndex->gold                       = x2;
          pMobIndex->exp                = x3;
          pMobIndex->height             = x4;
          pMobIndex->weight             = x5;
          pMobIndex->max_move           = x6;
          pMobIndex->max_mana           = x7;

And all shall be well with your world
       
Pages:<< prev 1 next >>