Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yahoo!, Remcon

Members: 1
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
614
BenitoVirg
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Cygwin packages needed
Forum Rules | Mark all | Recent Posts

Cygwin packages needed
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jan 15, 2004, 4:07 am
Go to the top of the page
Go to the bottom of the page

Naelphin

GroupMembers
Posts1
JoinedJan 15, 2004

Hello,

I am trying to compile under cygwin, but I don't think I have the right packages.

Which ones are needed for it to install?
       
Post is unread #2 Jan 15, 2004, 7:41 am
Go to the top of the page
Go to the bottom of the page

Greven
Magician
GroupMembers
Posts204
JoinedMar 5, 2005

I beleive that all you should need to compile any mud in cygwin is the gcc(assuming its c, if its c++ you might wanna grab that as well), the make package, and if your using it, the crypt package. There are some other helpful ones, such as grep, indent, and especially gdb. Hope that helps.
       
Post is unread #3 Jan 15, 2004, 8:44 am
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Since there's no reason not to use it, grab crypt. This way your pflies will work if you should decide to move up to a Linux based host.

And since I'll assume you're asking about AFKMud, you'll need the zlib package as well for the MCCP to work.
       
Post is unread #4 Jan 17, 2004, 10:08 am
Go to the top of the page
Go to the bottom of the page

oblivion

GroupMembers
Posts14
JoinedJan 4, 2004

what packages do you need in all to completly run afkmud
       
Pages:<< prev 1 next >>