Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, DotBot, Yandex, Google

Members: 0
Guests: 17
Stats
Files
Topics
Posts
Members
Newest Member
481
3,739
19,386
621
KellieBusb
Today's Birthdays
Rane (42)
Related Links
» SmaugMuds.org » General » Smaug Snippets » Overland snippet
Forum Rules | Mark all | Recent Posts

Overland snippet
< Newer Topic :: Older Topic > Stack error?? O_o

Pages:<< prev 1 next >>
Post is unread #1 Dec 28, 2003, 1:59 pm
Go to the top of the page
Go to the bottom of the page

DjNiVeK

GroupMembers
Posts12
JoinedDec 14, 2003

Ok, I installed the Overland snippet without bugs or problems (with compiling), but when I try to start smaug up, it says:

Sun Dec 28 22:53:59 2003 :: Reading in area files...
3 [main] smaug 2304 handle_exceptions: Exception: STATUS_ACCESS_VIOLATION
1436 [main] smaug 2304 open_stackdumpfile: Dumping stack trace to smaug.exe.stackdump.

The smaug.exe.stackdump shows this:

Exception: STATUS_ACCESS_VIOLATION at eip=00495C12
eax=00000030 ebx=005863D8 ecx=610D1494 edx=00000030 esi=00000000 edi=005A3460
ebp=0022FDE8 esp=0022FDB0 program=C:smaugdistareasmaug.exe
cs=001B ds=0023 es=0023 fs=0038 gs=0000 ss=0023
Stack trace:
Frame Function Args
0022FDE8 00495C12 (00000000, 005A3460, 00000039, 00000039)
0022FE18 004892CE (0047BBB1, 00000000, 00000039, 00000000)
0022FEE0 0047BF1A (00000001, 10021700, 10020330, 00000001)
0022FF40 61005018 (610CFEE0, FFFFFFFE, 000007E8, 610CFE04)
0022FF90 610052ED (00000000, 00000000, 00000000, 805B402B)
0022FFB0 0056B231 (0047BC2F, 037F0009, 0022FFF0, 77E5EB69)
0022FFC0 0040103C (00144460, 00000000, 7FFDF000, B6295CF4)
0022FFF0 77E5EB69 (00401000, 00000000, 78746341, 00000020)
End of stack trace


How do I get rid of this error? I tried some things already, but doesn't work O_o
       
Post is unread #2 Dec 28, 2003, 2:14 pm
Go to the top of the page
Go to the bottom of the page

DjNiVeK

GroupMembers
Posts12
JoinedDec 14, 2003

I might have an idea why this is happening. Could it be because of a too high areavnum? The basic .are's with the snippet have vnums in the 30000, but I don't use the 1 bil. vnums snippet. I temporary removed the .are's of the maps and changed the area list, and it works now O_o

--EDIT--
I'm able to start it up without mistakes now, but it doesn't seem like it puts me on the map when using an exit from 1202. Why?
       
Post is unread #3 Dec 29, 2003, 6:27 am
Go to the top of the page
Go to the bottom of the page

Xorith
The Null Value
GroupAFKMud Team
Posts254
JoinedFeb 23, 2003

I can't quite help with the problem, but what the hell does "O_o" mean?

-- X
       
Post is unread #4 Dec 29, 2003, 7:45 am
Go to the top of the page
Go to the bottom of the page

DjNiVeK

GroupMembers
Posts12
JoinedDec 14, 2003

O_o is a stupid smilie like thingie that I'm confused, lol
       
Post is unread #5 Dec 29, 2003, 8:06 am
Go to the top of the page
Go to the bottom of the page

DjNiVeK

GroupMembers
Posts12
JoinedDec 14, 2003

*slap self* I found out what was wrong...kinda really stupid mistake <!--emo&<_
       
Post is unread #6 Dec 30, 2003, 8:40 am
Go to the top of the page
Go to the bottom of the page

DjNiVeK

GroupMembers
Posts12
JoinedDec 14, 2003

Ok, I have a different question now. What I want to do is to make a different player or mob who is sneaking/hidden not appear on the map unless your char is using true sight or something. I don't know where to find the place in the code where it shows a different player on the map. Help plz?

--EDIT--
nm, I figured it out, it's now working properly
thanks anyways
       
Pages:<< prev 1 next >>