Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl

Members: 0
Guests: 2
Stats
Files
Topics
Posts
Members
Newest Member
481
3,740
19,396
630
JadaGerste
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Error when type save in Afkmud
Forum Rules | Mark all | Recent Posts

Error when type save in Afkmud
< Newer Topic :: Older Topic > error everytime i type save

Pages:<< prev 1 next >>
Post is unread #1 Dec 20, 2010, 7:09 am
Go to the top of the page
Go to the bottom of the page

Sherm
Fledgling
GroupMembers
Posts33
JoinedDec 20, 2010

I get this everytime I type save.

Bugs: [*****] BUG: save: fopen
Bugs: Obtained 9 stack frames.
Bugs: ../src/afkmud(_Z3bugPKcz+0x1cc) [0x53207f]
Bugs: ../src/afkmud(_ZN9char_data4saveEv+0x252) [0x5e6498]
Bugs: ../src/afkmud(do_save+0x2f) [0x5e65ec]
Bugs: ../src/afkmud(_Z9interpretP9char_dataSs+0x1061) [0x526a3a]
Bugs: ../src/afkmud(_Z13process_inputv+0x2d2) [0x521fc3]
Bugs: ../src/afkmud(_Z9game_loopv+0x69) [0x5225e1]
Bugs: ../src/afkmud(main+0x1f6) [0x523066]
Bugs: /lib64/libc.so.6(__libc_start_main+0xfd) [0x2aaab962fb7d]
Bugs: ../src/afkmud() [0x456dc9]
Saved...
       
Post is unread #2 Dec 20, 2010, 2:41 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,644
JoinedJan 1, 2002

That's an indication that the save routine isn't able to write to the pfile. The permissions on the directory your game is in are probably not set right.
       
Post is unread #3 Dec 21, 2010, 9:40 am
Go to the top of the page
Go to the bottom of the page

Sherm
Fledgling
GroupMembers
Posts33
JoinedDec 20, 2010

thanks I will look at it :)

       
Post is unread #4 Dec 21, 2010, 11:26 am   Last edited Dec 21, 2010, 11:49 am by Sherm
Go to the top of the page
Go to the bottom of the page

Sherm
Fledgling
GroupMembers
Posts33
JoinedDec 20, 2010

This was the issue, I needed to had the mud group i created to the lib64 directory. Once this was done everything worked fine. I am current runing afkmud on opensuse 11.3 64 bit.
       
Post is unread #5 Dec 21, 2010, 7:27 pm
Go to the top of the page
Go to the bottom of the page

Conner
Sorcerer
GroupMembers
Posts870
JoinedMay 8, 2005

Don't feel bad, it's a fairly common mistake. :)
       
Pages:<< prev 1 next >>