Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Yahoo!, Google

Members: 0
Guests: 8
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Bugfix Lists » SWR FUSS Bugfix List » [Bug] Launchship sending mess...
Forum Rules | Mark all | Recent Posts

[Bug] Launchship sending messages to wrong/NULL rooms.
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jul 2, 2009, 10:41 pm
Go to the top of the page
Go to the bottom of the page

Kayle
Off the Edge of the Map
GroupAdministrators
Posts1,195
JoinedMar 21, 2006

Bug: Launchship sending message to wrong room.
Danger: Minor - Launchship tries to send messages to wrong/NULL rooms.
Found by: Banner
Fixed by: Banner

---

space.c, launchship
Locate:
echo_to_room( AT_GREEN, get_room_index( ship->location ), "Launch complete.\r\n" );


Replace with:
echo_to_room( AT_GREEN, get_room_index( ship->pilotseat ), "Launch complete.\r\n" );


Location is set to 0 at the top of the function. So sending it to ship->location is a null room. It should be sending it to the pilot of the ship anyway.

       
Pages:<< prev 1 next >>