Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, Google, Yandex

Members: 0
Guests: 10
Stats
Files
Topics
Posts
Members
Newest Member
481
3,735
19,368
618
Micheal64X
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SmaugFUSS » Creating a skill slight issue
Forum Rules | Mark all | Recent Posts

Creating a skill slight issue
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jan 13, 2008, 2:47 pm
Go to the top of the page
Go to the bottom of the page

Remcon
Geomancer
GroupAdministrators
Posts1,873
JoinedJul 26, 2005

On your mud type sset create skill <name>
and then just do an sset save skill table
Then if you look in the file you will see something like this
#SKILL
Name         testing~
Type         unknown
Info         0
Flags        0
Code         (null)
Dammsg       ~
Minlevel     0
End

A quick look at how it creates the code shows that it does in fact set the code to spell_smaug
It just never sets the spell_fun_name so it writes (null) to the file. Simple fix is to open up skills.c and toss in for it to set skill->spell_fun_name = str_dup( "spell_smaug" ); Now if you go down to where it allows you to set the code for a spell/skill it doesn't dispose of a code before setting another one so that is a leak :) Just passing on what little i find hope it helps someone out :)
       
Pages:<< prev 1 next >>