Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Bing

Members: 0
Guests: 6
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » General » Smaug Snippets » Resolver problem
Forum Rules | Mark all | Recent Posts

Resolver problem
< Newer Topic :: Older Topic > Resolver problem

Pages:<< prev 1 next >>
Post is unread #1 Feb 8, 2003, 2:14 pm
Go to the top of the page
Go to the bottom of the page

xerves

GroupMembers
Posts4
JoinedFeb 8, 2003

I was installing the resolver because the old dns_slave thing is a little buggy. Anyway, everything works fine till I get to the dns.c file

Fear 1.1 is now compiling... o/stat_obj.o
Fear 1.1 is now compiling... o/tables.o
Fear 1.1 is now compiling... o/track.o
Fear 1.1 is now compiling... o/treasure.o
Fear 1.1 is now compiling... o/update.o
Fear 1.1 is now compiling... o/dns.o
In file included from mud.h:383,
from dns.c:27:
finger.h:29: parse error before `FILE'
In file included from mud.h:394,
from dns.c:27:
i3.h:366: parse error before `FILE'
i3.h:367: parse error before `FILE'
In file included from dns.c:27:
mud.h:4632: parse error before `*'
mud.h:4632: warning: type defaults to `int' in declaration of `fpReserve'
mud.h:4632: warning: data definition has no type or storage class
mud.h:4633: parse error before `*'
mud.h:4633: warning: type defaults to `int' in declaration of `fpLOG'
mud.h:4633: warning: data definition has no type or storage class
mud.h:5812: parse error before `*'
mud.h:5813: parse error before `*'
mud.h:5814: parse error before `*'


Now, my header files are intact and everything seems to be working ok till I hit this file and it goes nuts. Hrm, am I missing something because I have never had a problem like this before.

--Xerves
       
Post is unread #2 Feb 8, 2003, 2:40 pm
Go to the top of the page
Go to the bottom of the page

xerves

GroupMembers
Posts4
JoinedFeb 8, 2003

This is not a problem with your code, it has something to do with my Makefile, I am current working on it. Very damn strange though. What a lovely day :-)

--X
       
Post is unread #3 Feb 8, 2003, 4:38 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Heh, noticed me get a bit agitated with Pharas again eh? :P

Damn strange indeed. Doesn't look quite right, but then again.... with the things I've seen before....

Seems unlikely to me, but is dns.c the first file in your Makefile that needs file I/O functions?
       
Post is unread #4 Mar 6, 2003, 3:04 pm
Go to the top of the page
Go to the bottom of the page

xerves

GroupMembers
Posts4
JoinedFeb 8, 2003

Just a follow up, for information sake...

It turned out to be the Makefile. I made a makefile that works like yours (seems cleaner the way you did it). Anyway, anytime I would add a new .c file after changing the Makefile, it would go all nuts like that. It did that in both cygwin in linux, so I am not sure what the hell was up with that (since I don't really know all that much about the changes you made, I was not really sure where to begin, so I just went back to the old Makefile). I am guessing you have added a new .c file since you started using that format?
       
Pages:<< prev 1 next >>