Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, Majestic-12, Yandex

Members: 0
Guests: 13
Stats
Files
Topics
Posts
Members
Newest Member
481
3,740
19,388
628
PabloL3189
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SWFOTE FUSS » Log reports an incorrect erro...
Forum Rules | Mark all | Recent Posts

Log reports an incorrect error with ship modules
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Sep 8, 2006, 6:20 am
Go to the top of the page
Go to the bottom of the page

Keberus
Conjurer
GroupFUSS Project Team
Posts341
JoinedJun 4, 2005

This is just something I noticed. Ship modules load fine but are reported as errors. Easy fix

in space.c
function fread_ship

find:
            if( !str_cmp( word, "Module" ) )
            {
               MODULE_DATA *mod;
               line = fread_line( fp );
               CREATE( mod, MODULE_DATA, 1 );
               LINK( mod, ship->first_module, ship->last_module, next, prev );
               x1 = x2 = 0;
               sscanf( line, "%d %d", &x1, &x2 );
               mod->affect = x1;
               mod->ammount = x2;
            }


and change to:
            if( !str_cmp( word, "Module" ) )
            {
               MODULE_DATA *mod;
               line = fread_line( fp );
               CREATE( mod, MODULE_DATA, 1 );
               LINK( mod, ship->first_module, ship->last_module, next, prev );
               x1 = x2 = 0;
               sscanf( line, "%d %d", &x1, &x2 );
               mod->affect = x1;
               mod->ammount = x2;
               fMatch = TRUE;
            }


Basically the mud was reporting that Module didnt match when it did....someone just forgot the fMatch setting.


Peace,
KeB
       
Post is unread #2 Sep 8, 2006, 6:47 am
Go to the top of the page
Go to the bottom of the page

kiasyn
Magician
GroupMembers
Posts121
JoinedJun 30, 2006

should probably also be a break; in there, just after the fMatch = TRUE
       
Pages:<< prev 1 next >>