Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, Yandex, Google

Members: 0
Guests: 15
Stats
Files
Topics
Posts
Members
Newest Member
481
3,737
19,381
619
Alexander
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Bugfix Lists » SmaugFUSS Bugfix List » [Bug] vassign enhancement fai...
Forum Rules | Mark all | Recent Posts

[Bug] vassign enhancement fails to set proper area flags
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Sep 12, 2005, 6:12 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,643
JoinedJan 1, 2002

Bug: vassign enhancement fails to set proper area flags
Danger: Medium - Inability to savearea newly generated area
Found by: Remcon
Fixed by: Remcon
Ignore if you do not have the vassign enhancement

---

act_wiz.c, do_vassign

Locate:
   if( !IS_SET( tarea->status, AREA_DELETED ) )
   {
      snprintf( filename, 256, "%s%s", BUILD_DIR, tarea->filename );
      fold_area( tarea, filename, FALSE );
   }


Change to:
   if( !IS_SET( tarea->status, AREA_DELETED ) )
   {
      SET_BIT( tarea->status, AREA_LOADED );
      SET_BIT( tarea->flags, AFLAG_PROTOTYPE );
      snprintf( filename, 256, "%s%s", BUILD_DIR, tarea->filename );
      fold_area( tarea, filename, FALSE );
   }


A newly generated area created with vassign is never assigned a prototype flag, and is never told that it is "loaded" into the game already when it's first made. This will cause the savearea command to fail and be unable to save the area.
       
Pages:<< prev 1 next >>