Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
tintin++ ogg sound player script for linux
Author: Robert Smith
Submitted by: Vladaar
6Dragons ogg Soundpack
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
Users Online
CommonCrawl, Bing

Members: 0
Guests: 10
Stats
Files
Topics
Posts
Members
Newest Member
481
3,739
19,386
626
UnaMcGlinn
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Bugfix Lists » SmaugFUSS Bugfix List » [Bug] Installarea not properl...
Forum Rules | Mark all | Recent Posts

[Bug] Installarea not properly handling area lists for installed areas
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Mar 5, 2005, 3:59 pm   Last edited May 11, 2005, 6:42 pm by Samson
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,643
JoinedJan 1, 2002

Bug: Installarea does not properly handle moving newly installed areas from the prototype list to the installed list.
Danger: low
Found by: Samson
Fixed by: Samson
---
[build.c]

In the do_installarea function find:

  /* Remove from prototype area list */
  UNLINK( tarea, first_build, last_build, next, prev );

  /* Add to real area list */
  LINK( tarea, first_area, last_area, next, prev );


Below that add:

  /* Remove it from the prototype sort list. BUGFIX: Samson 4-15-03 */
  UNLINK( tarea, first_bsort, last_bsort, next_sort, prev_sort );

  /* Sort the area into it's proper sort list. BUGFIX: Samson 4-15-03 */
  sort_area( tarea, FALSE );
       
Pages:<< prev 1 next >>