Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, DotBot

Members: 0
Guests: 9
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Cannot compile 1.76a
Forum Rules | Mark all | Recent Posts

Cannot compile 1.76a
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Sep 20, 2005, 7:27 pm   Last edited Sep 20, 2005, 7:28 pm by Zarius
Go to the top of the page
Go to the bottom of the page

Zarius
Apprentice
GroupMembers
Posts69
JoinedApr 23, 2002

When I try to compile I get this error, never seen this one before

make -s afkmud
typeinfo for char_morph*: discarded in section `.gnu.linkonce.r._ZTIP10char_morph' from o/polymorph.o
collect2: ld returned 1 exit status

Using Ubuntu 5.04 if it matters.

I can compile other mud codes fine, even ones that use g++
       
Post is unread #2 Sep 20, 2005, 7:35 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Blargh, not that again. What compiler version are you using and on what OS?
       
Post is unread #3 Sep 20, 2005, 7:37 pm
Go to the top of the page
Go to the bottom of the page

Zarius
Apprentice
GroupMembers
Posts69
JoinedApr 23, 2002

Samson said:

Blargh, not that again. What compiler version are you using and on what OS?


Reading specs from /usr/lib/gcc-lib/i486-linux/3.3.5/specs
Configured with: ../src/configure -v --enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --with-system-zlib --enable-nls --without-included-gettext --enable-__cxa_atexit --enable-clocale=gnu --enable-debug --enable-java-gc=boehm --enable-java-awt=xlib --enable-objc-gc i486-linux
Thread model: posix
gcc version 3.3.5 (Debian 1:3.3.5-8ubuntu2)


Ubuntu 5.04
       
Post is unread #4 Sep 20, 2005, 7:44 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

What the hell is it with Debian anyway? Why does it always have to be such a pain :P

Anyway, I know what's causing it, just don't know exactly why. Need to change the DISPOSE and STRFREE macros back to this:

#define DISPOSE(point)                      \
do                                          \
{                                           \
   if( (point) )                            \
   {                                        \
      free( (point) );                      \
      (point) = NULL;                       \
   }                                        \
} while(0)

#define STRFREE(point)                          \
do                                              \
{                                               \
   if((point))                                  \
   {                                            \
      if( str_free((point)) == -1 )             \
         bug( "&RSTRFREEing bad pointer: %s, line %d", __FILE__, __LINE__ ); \
      (point) = NULL;                           \
   }                                            \
} while(0)


For some reason I have yet to figure out, Debian refuses to accept the otherwise valid code.
       
Post is unread #5 Sep 21, 2005, 4:46 pm
Go to the top of the page
Go to the bottom of the page

gnutux

GroupMembers
Posts1
JoinedSep 21, 2005

The problem here is that Debian has tonnes of different workarounds for something really simple. It has some of its own rules that do not exist on other Linux systems. That is why you sometimes need Debian compatible codes.

gnutux
       
Post is unread #6 Sep 21, 2005, 7:01 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Which is unfortunate, and the reason why in some cases code is not allowed to advance without being rewritten to accomadate it. :)
       
Post is unread #7 Oct 18, 2005, 6:57 pm
Go to the top of the page
Go to the bottom of the page

Zarius
Apprentice
GroupMembers
Posts69
JoinedApr 23, 2002

On the bright side, the newest Ubuntu 5.10 compiles 1.76a without problems.

Woo!
       
Post is unread #8 Sep 7, 2006, 1:15 pm
Go to the top of the page
Go to the bottom of the page

ransom
Fledgling
GroupMembers
Posts22
JoinedSep 7, 2006

Not sure if this will help aneyone else but I was having the same problem in debian SARGE... I happend to rember that other code bases seem to have problem with the nerwr GCC/G++ compling engins.. I was trying with g++-3.3 and using the "patch" and getting an error on the lines of "pointer must be a defined type"..

So.. I made sure I had the 2.95 compiler installed and in the make file changed the g++ line to g++-2.95 did a make clean and poof it worked. I had it working with 3.3 also.. but that was on a testing install and this one is strictly stale.. hope this helps someone else..

btw I was compiling AFKmud-2.77 not 2.76a though it might & probably would work with 2.76a aswell
       
Post is unread #9 Sep 7, 2006, 8:15 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

You actually got the code to compile under 2.95 eh? The last time I tried that it failed miserably. AFKMud has been much more difficult to compile in OLDER environments such as 2.95 and even 3.0 for awhile now. g++ 3.1 on up through 4.1 haven't really been that much of a problem. Until you get into the BSD and Debian systems. For whatever mysterious reason, those dislike the code. But then I've heard plenty of people complain about how BSD and Debian tend to hate alot of other mud code.

btw I was compiling AFKmud-2.77 not 2.76a though it might & probably would work with 2.76a aswell


Heh, no, not unless you're back from the future you didn't :P
I'm sure you meant 1.77 and 1.76a though.
       
Pages:<< prev 1 next >>