Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
Bug in do_drag( )
Oct 8, 2017, 12:40 am
By GatewaySysop
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Beastmaster 6D sound files
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, DotBot, Sogou

Members: 0
Guests: 7
Stats
Files
Topics
Posts
Members
Newest Member
476
3,704
19,231
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » 1.53 and traps
Forum Rules | Mark all | Recent Posts

1.53 and traps
< Newer Topic :: Older Topic > Yes, tis me again

Pages:<< prev 1 next >>
Post is unread #1 Jul 17, 2003, 2:06 pm
Go to the top of the page
Go to the bottom of the page

Moonwolf

GroupMembers
Posts43
JoinedAug 25, 2005

Hi again,

OK, setting traps is confusing.

I've been trying to set a trap on a door that leads down, and I want it to go off when someone actually tries to go down, that is after opening the door.

So, I type

reset trap  12 99 room


Which sets up the reset. Then I reset the area, get the obj stats on the object "trap".

I then do

oset trap v0 99 to set the charges
oset trap v4 5 and oset trap v5 15 to set the damage range.

All looks good so far. So I then turn my attentions to v3. Now according to Values.txt, v3 should be set to 32769 (ROOM and MOVING DOWN), and ostat seems to say that's so:


Value[3] - Trap Flags (32769): Room DownValue[4] - Min. Damage: 0


The problem is, it doesn't trigger when they go down.

So I'm totally confused how I'm supposed to get this working and would appreciate some advice.

Kathi
       
Post is unread #2 Jul 17, 2003, 7:50 pm
Go to the top of the page
Go to the bottom of the page

kilroy
Magician
GroupMembers
Posts122
JoinedMay 1, 2002

is the area still in proto?
I have had some problem like that too - but installed the area, and it worked.
Kilroy
       
Post is unread #3 Jul 17, 2003, 10:01 pm
Go to the top of the page
Go to the bottom of the page

Moonwolf

GroupMembers
Posts43
JoinedAug 25, 2005

Hmm, I hadn't thought of that. I figured out that wandering monsters wouldn't while proto, I should have thought of that one as a reason too ...

So I'm doing the right things, at least?

Kathi
       
Pages:<< prev 1 next >>