Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex

Members: 0
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Possible Problem
Forum Rules | Mark all | Recent Posts

Possible Problem
< Newer Topic :: Older Topic > Possible problem with Adelete, Zone

Pages:<< prev 1 next >>
Post is unread #1 Jan 25, 2004, 6:49 pm
Go to the top of the page
Go to the bottom of the page

RapidRunner

GroupMembers
Posts72
JoinedDec 4, 2003

heh, i typed adelete immtrain.are, then zones it showed
(null) (null) V: 21100 - 21299

Then typed it again, mud crashed.. Here is a Core Dump..

(gdb) bt#0  0x080ebf37 in show_vnums(char_data*, short) (ch=0x87f3c60, proto=0) at db.c:6918#1  0x080ec028 in do_zones (ch=0x87f3c60,    argument=0x883f8c0 "e[1;37mFilename        Area Name", ' ' , "Vnums

e[0;36mentry.are       Halls of Creation", ' ' , "V:   100 - 199  
e[0;36mastral.are      The Astral Plane      "...) at db.c:6952#2  0x0810f2ec in interpret(char_data*, char*) (ch=0x87f3c60, argument=0xbffff15d "";)    at interp.c:910#3  0x080dc765 in game_loop() () at comm.c:4118#4  0x080dd26f in main (argc=6, argv=0x87f4850) at comm.c:4553#5  0x42015704 in __libc_start_main () from /lib/tls/libc.so.6(gdb)


*Got tired of waiting on Bugzilla to send me my password.. *
       
Post is unread #2 Jan 26, 2004, 3:45 am
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Fix for this:

act_wiz.c, close_area, find:

   UNLINK( pArea, first_area, last_area, next, prev );   DISPOSE( pArea );


Change to:

   UNLINK( pArea, first_area_nsort, last_area_nsort, next_sort_name, prev_sort_name );   UNLINK( pArea, first_area_vsort, last_area_vsort, next_sort, prev_sort );   UNLINK( pArea, first_area, last_area, next, prev );   DISPOSE( pArea );


mud.h, find:

extern AREA_DATA *first_area;extern AREA_DATA *last_area;


Add below:

extern AREA_DATA *first_area_nsort;extern AREA_DATA *last_area_nsort;extern AREA_DATA *first_area_vsort;extern AREA_DATA *last_area_vsort;
       
Pages:<< prev 1 next >>