Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
 parse description bug
Today, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Users Online
CommonCrawl, Google, Remcon

Members: 1
Guests: 14
Stats
Files
Topics
Posts
Members
Newest Member
477
3,706
19,240
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SmaugFUSS » SMAUGFUSS1.9.2 Vaults and Hou...
Forum Rules | Mark all | Recent Posts

SMAUGFUSS1.9.2 Vaults and Houses Not Saving Objects Correctly?
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Apr 22, 2016, 8:41 pm
Go to the top of the page
Go to the bottom of the page

Sadiq
Fledgling
GroupMembers
Posts24
JoinedJan 7, 2010

Okay, was playing around with the the most recent version of SMAUGFUSS here, and noticed something odd. Is it just me, or are objects not being nested in vaults and houses? They aren't disappearing...but they aren't saving inside of containers, either.

I'm working on a Windows box, compiling with Cygwin.
       
Post is unread #2 Apr 23, 2016, 9:13 am
Go to the top of the page
Go to the bottom of the page

Sadiq
Fledgling
GroupMembers
Posts24
JoinedJan 7, 2010

Nevermind. Got it all sussed out :p
       
Post is unread #3 Oct 1, 2016, 11:03 am
Go to the top of the page
Go to the bottom of the page

Sadiq
Fledgling
GroupMembers
Posts24
JoinedJan 7, 2010

UPDATE: Here's the fix, if any are interested or having the same issue...

Open clans.c and find fread_storage().

Change this:
    fread_obj( supermob, fp, OS_VAULT );

To this:
    fread_obj( supermob, fp, OS_CARRY );
       
Post is unread #4 Oct 4, 2016, 8:48 am
Go to the top of the page
Go to the bottom of the page

Zavor
Fledgling
GroupMembers
Posts5
JoinedSep 8, 2016

Sadiq,

Recently was messing around with SmaugFUSS 1.9.2, and experienced something similar, but the issue was an entire area.

Was working with Gods.are, had already aassign'd it to myself, then made changes, used foldarea. On reboot of the MUD, all changes would be lost.

Ensured I had all the working permissions in the directory and for all the files (using chmod for rwx perms), tried again, still no change and same issue.

You experience any of this while you were sussing this stuff out? If not, I'm going to form a separate forum post, but figured I'd ask first.

Thanks!
-Zavor
       
Post is unread #5 Oct 4, 2016, 9:34 am
Go to the top of the page
Go to the bottom of the page

Sadiq
Fledgling
GroupMembers
Posts24
JoinedJan 7, 2010

Zavor said:

Sadiq,

Recently was messing around with SmaugFUSS 1.9.2, and experienced something similar, but the issue was an entire area.

Was working with Gods.are, had already aassign'd it to myself, then made changes, used foldarea. On reboot of the MUD, all changes would be lost.

Ensured I had all the working permissions in the directory and for all the files (using chmod for rwx perms), tried again, still no change and same issue.

You experience any of this while you were sussing this stuff out? If not, I'm going to form a separate forum post, but figured I'd ask first.

Thanks!
-Zavor


gods.are in FUSS inherited a little quirk from the original SMAUG distro...namely that it had 2 rooms, 1 object and 1 mobile, and the vnum ranges for each were set accordingly. If you tried adding additional rooms, objects, or mobiles to gods.are, you have to make sure that you bump the vnum ranges before building in the area. Basically, you need to do the following (in this order): This assumes you want to increase the vnum ranges to 1299...suit yourself.

AASSIGN yourself the area
ASET gods.are hi_room 1299
ASET gods.are hi_obj 1299
ASET gods.are hi_mob 1299
GOTO 1299
OCREATE 1299 last object
MCREATE 1299 last mob
FOLDAREA gods.are

That should fix you up, hopefully. Maybe a 'fixed' gods.are should be included in the FUSS distro...

Hope this helps.

Sadiq
       
Post is unread #6 Oct 4, 2016, 10:39 am
Go to the top of the page
Go to the bottom of the page

Zavor
Fledgling
GroupMembers
Posts5
JoinedSep 8, 2016

Sadiq,

You're awesome. I was getting fairly frustrated with FUSS (to the point where I wiped the directory and setup LoP instead, as I thought this issue would be across all areas- didn't occur to me it could be just the one area, so I thought it was a codebase issue). I want to thank you for that.

I may consider doing some basic quality-of-life fixes to the FUSS distro (to Gods.are and the cmdtable where the say command and several other commands are misprioritized) and uploading another copy of it, or getting it over to Samson to upload as an "official" file.

Thanks again!
-Zavor
       
Pages:<< prev 1 next >>