Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
Bug in do_drag( )
Oct 8, 2017, 12:40 am
By GatewaySysop
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Beastmaster 6D sound files
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yahoo!

Members: 0
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
476
3,704
19,231
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » General » Coding » Cygwin x64 issue
Forum Rules | Mark all | Recent Posts

Cygwin x64 issue
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Feb 4, 2016, 8:30 pm
Go to the top of the page
Go to the bottom of the page

Embracing
Fledgling
GroupMembers
Posts3
JoinedSep 29, 2010

Hi everyone,

This is my first post to the forums, so please go easy on my newbishness. I am using Cygwin 64-bit to run the LoP codebase. However, I have hit a wall and hope that if I post it here, someone may know what I am looking at. Here it is...

Program received signal SIGSEGV, Segmentation fault.
___chkstk_ms () at /usr/src/debug/gcc-4.9.3-1/libgcc/config/i386/cygwin.S:146
146 orq $0x0, (%rcx) /* probe there */

(gdb) bt
#0 ___chkstk_ms () at /usr/src/debug/gcc-4.9.3-1/libgcc/config/i386/cygwin.S:146
#1 0x0000000100405573 in do_say (ch=0x60061f7d0, argument=0xffe737b4 "prototyped";) at act_comm.c:471
#2 0x00000001004adb2c in interpret (ch=ch@entry=0x60061f7d0, argument=0xffe737b4 "prototyped",
argument@entry=0xffe737b0 "say prototyped";) at interp.c:430
#3 0x00000001004d861d in mprog_do_command (cmnd=<optimized out>,
cmnd@entry=0xffea5330 "say prototyped", mob=mob@entry=0x60061f7d0, actor=actor@entry=0x6007a3560,
obj=obj@entry=0x0, vo=vo@entry=0x0, rndm=rndm@entry=0x6007a3560, ignore=false, ignore_ors=false)
at mud_prog.c:2448
#4 0x00000001004d8b99 in mprog_driver (com_list=<optimized out>, mob=mob@entry=0x60061f7d0,
actor=actor@entry=0x6007a3560, obj=obj@entry=0x0, vo=vo@entry=0x0,
single_step=single_step@entry=false) at mud_prog.c:2177
#5 0x00000001004d9457 in mprog_wordlist_check (arg=arg@entry=0xfff691f0 "test",
mob=mob@entry=0x60061f7d0, actor=actor@entry=0x6007a3560, obj=obj@entry=0x0, vo=vo@entry=0x0,
type=type@entry=1) at mud_prog.c:2625
#6 0x00000001004d94f4 in mprog_speech_trigger (txt=txt@entry=0xfff691f0 "test",
actor=actor@entry=0x6007a3560) at mud_prog.c:2991
#7 0x0000000100405c94 in do_say (ch=0x6007a3560, argument=<optimized out>;) at act_comm.c:654
#8 0x00000001004adb2c in interpret (ch=0x6007a3560, argument=0xffffc734 "test",
argument@entry=0xffffc730 "say test";) at interp.c:430
#9 0x0000000100472805 in game_loop () at comm.c:737
#10 0x0000000100472c99 in main (argc=2, argv=0xffffcc20) at comm.c:538

(gdb) frame 1
#1 0x0000000100405573 in do_say (ch=0x60061f7d0, argument=0xffe737b4 "prototyped";) at act_comm.c:471
471 {

(gdb) frame 0
#0 ___chkstk_ms () at /usr/src/debug/gcc-4.9.3-1/libgcc/config/i386/cygwin.S:146
146 orq $0x0, (%rcx) /* probe there */

Can anyone help me?

Thanks,
Embracing
       
Post is unread #2 Feb 5, 2016, 3:28 pm
Go to the top of the page
Go to the bottom of the page

Remcon
Geomancer
GroupAdministrators
Posts1,857
JoinedJul 26, 2005

well it looks like you were testing a program mind putting the info on the program you were testing here so there is a bit more info to help find the issue? the reason i ask is it looks like it crashed on do_say but I can easily force a mobile to say something without issues.
       
Post is unread #3 Feb 6, 2016, 4:58 pm
Go to the top of the page
Go to the bottom of the page

DoC_Imp
Fledgling
GroupMembers
Posts1
JoinedFeb 5, 2016

Yeah, I'll send it to you via messanger. I think the issue is mainly with the codebase I hold due to the modification that I have been doing to it. Thank you for your expertise in the matter.
       
Post is unread #4 Feb 6, 2016, 6:27 pm
Go to the top of the page
Go to the bottom of the page

Remcon
Geomancer
GroupAdministrators
Posts1,857
JoinedJul 26, 2005

well since it is crashing on do_say try just forcing the npc to say something and see if it still crashes
       
Pages:<< prev 1 next >>