Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
Bug in do_drag( )
Oct 8, 2017, 12:40 am
By GatewaySysop
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Beastmaster 6D sound files
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Google, Yandex, DotBot

Members: 0
Guests: 10
Stats
Files
Topics
Posts
Members
Newest Member
476
3,704
19,231
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SmaugFUSS » Color Code Problem I think......
Forum Rules | Mark all | Recent Posts

Color Code Problem I think....
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jul 21, 2010, 4:33 pm
Go to the top of the page
Go to the bottom of the page

dbna2
Sorcerer
GroupMembers
Posts600
JoinedDec 2, 2008

For some reason when ever I post links on any channels colors codes appear.




<<IMM:OOC>> {The Warrior of Darkness} Hokai: -- 'http://www.realmsofdespair.com/smaug/herne/smaug.html'&D&w'&D

it's like that for all channels. but each one different color codes show up. I am not sure what causes it or where to look.

the link I am trying to send is:
http://www.realmsofdespair.com/smaug/herne/smaug.html
       
Post is unread #2 Jul 21, 2010, 4:45 pm
Go to the top of the page
Go to the bottom of the page

Banner
Magician
GroupMembers
Posts169
JoinedNov 29, 2005

There's a portion of the code that strips color codes out of http links so ampersand(&;) show up correctly in links. Adding a space after pasting a link will return the color codes at the end of the string correctly.
       
Post is unread #3 Jul 21, 2010, 4:56 pm
Go to the top of the page
Go to the bottom of the page

dbna2
Sorcerer
GroupMembers
Posts600
JoinedDec 2, 2008

is there away to make it not need a space?
       
Post is unread #4 Jul 21, 2010, 5:09 pm   Last edited Jul 21, 2010, 5:09 pm by Kayle
Go to the top of the page
Go to the bottom of the page

Kayle
Off the Edge of the Map
GroupAdministrators
Posts1,195
JoinedMar 21, 2006

Not without redoing the way it parses for links to avoid screwing them up. I'm pretty sure adding a space at the end is a lesser price then having to double every &, ^ and } in a link to get them to show up properly.
       
Post is unread #5 Jul 21, 2010, 5:11 pm
Go to the top of the page
Go to the bottom of the page

dbna2
Sorcerer
GroupMembers
Posts600
JoinedDec 2, 2008

maybe it will be easier if I just go through and make it add a space at the end of each channel.
       
Post is unread #6 Jul 21, 2010, 5:32 pm   Last edited Jul 21, 2010, 5:33 pm by dbna2
Go to the top of the page
Go to the bottom of the page

dbna2
Sorcerer
GroupMembers
Posts600
JoinedDec 2, 2008

Thanks for the details though :)
       
Pages:<< prev 1 next >>