Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Google, Vladaar, Yandex

Members: 1
Guests: 8
Stats
Files
Topics
Posts
Members
Newest Member
479
3,708
19,242
614
BenitoVirg
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Bugfix Lists » SWR FUSS Bugfix List » [Bug] MobProgs fails to assig...
Forum Rules | Mark all | Recent Posts

[Bug] MobProgs fails to assign to mobs/objs correctly.
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Apr 21, 2010, 3:23 am
Go to the top of the page
Go to the bottom of the page

Kayle
Off the Edge of the Map
GroupAdministrators
Posts1,195
JoinedMar 21, 2006

Bug: MobProgs fail to assign to mobs/objs correctly
Danger: Low - Progs just won't work.
Found by: Dekar
Fixed by: Remcon

---

db.c

In fread_fuss_mobprog, Find:
               SET_BIT( prog_target->progtypes, 1 << mprg->type );


Change to:
               SET_BIT( prog_target->progtypes, mprg->type );


In fread_fuss_objprog, Find:
               SET_BIT( prog_target->progtypes, 1 << mprg->type );


Change to:
               SET_BIT( prog_target->progtypes, mprg->type );
       
Pages:<< prev 1 next >>