Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yahoo!, Bing

Members: 0
Guests: 10
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » General » General Discussions » New coder trying to decide on...
Forum Rules | Mark all | Recent Posts

New coder trying to decide on a codebase. (Need opinions)
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Mar 25, 2010, 1:45 am
Go to the top of the page
Go to the bottom of the page

Tyler-yo
Fledgling
GroupMembers
Posts4
JoinedMar 24, 2010

Hi I'm a relatively new coder starting a new scifi/dystopic MUD and I cant decide between SWR codebases. I'm currently running both SWfote 2.1 and SWR 2.0 Refactor, and comparing them. I love the player planet building and levelless system in SWR 2.0, but compared to swfote its kind of bare when it comes to features, swfote is far more fleshed out as far as space goes and skills go. But looking aorund I hear things about how swfote is full of serious bugs. So I'm just not sure.

What's some honest opinions on what would be a better codebase for a new coder?
       
Post is unread #2 Mar 25, 2010, 3:11 am
Go to the top of the page
Go to the bottom of the page

ayuri
Magician
GroupMembers
Posts239
JoinedJun 13, 2008

Nearly all of the 'serious' bugs from swfote 2.1.5 found on swfote.sf.net can be fixed with most of the bugfix list here on smaugmuds. I am running a highly modified swfote 2.1.5 and all the bugs that I've found I've tried to post them here as they likely effect the FUSS package's of swfote and swr. The reverse applies too. Some of the swr fixes applies to swfote, you just have to spend the time and look at your code.

That said about the non fuss packages you are better off using a fuss package. If I had the time, I'd drop my legacy code for FUSS for the keyed area format's and other nifty things. However, as I've a lot of code and not a lot of time I keep plugging away at what I already have, back porting fixes.

Down side of FUSS packages you'd need to install some of the nifty features by hand, and some of them have major bugs (cargo mod for example).

As to honest opinions, if I could I'd move what I have to swfotefuss. I love fote, even with all of its short comings, it was after all my first mud. You never forget your first :D

ayuri
       
Post is unread #3 Mar 25, 2010, 4:24 pm
Go to the top of the page
Go to the bottom of the page

Keberus
Conjurer
GroupFUSS Project Team
Posts341
JoinedJun 4, 2005

If you are new to coding then I would definitely recommend either SWR FUSS or SWFOTE FUSS, as they are maintained pretty well, and very stable "out of the box". The other nice thing is that even though you may not know how to fix something, the bugfix section here is very easy to follow.
       
Post is unread #4 Mar 26, 2010, 3:08 am
Go to the top of the page
Go to the bottom of the page

Tyler-yo
Fledgling
GroupMembers
Posts4
JoinedMar 24, 2010

Thanks for the advice.

Well I ran the swfoteFUSS at first but switched when I saw all the new features on the swfote 2.1

Are the bugs worse on 2.1 and Is it worth switching for the bugfix section?
       
Post is unread #5 Mar 26, 2010, 1:09 pm
Go to the top of the page
Go to the bottom of the page

ayuri
Magician
GroupMembers
Posts239
JoinedJun 13, 2008

Yes, the bugs in nonfuss (2.1.5) are pretty nasty. Most of the ones found here in the bug list forum here will apply to the core game. However, since 2.1.5 has a lot more snippet's installed some of them have pretty nasty bugs; I don't believe to many of the snippet bug fixes are here. Keb, as far as I know, hasn't updated the nonfuss branch in a long time. As he said above, you are better off starting with the FUSS branch.

ayuri
       
Post is unread #6 Mar 27, 2010, 12:10 am
Go to the top of the page
Go to the bottom of the page

Tyler-yo
Fledgling
GroupMembers
Posts4
JoinedMar 24, 2010

I took your advice and loaded up swrfote fuss 1.4 and for some reason it wont compile.

when I type make I get this:


make -s swr
Compiling o/imc.o....
Compiling o/11.o....
Compiling o/act_comm.o....
Compiling o/act_info.o....
Compiling o/act_move.o....
cc1plus: warnings being treated as errors
act_move.c: In function âshort int encumbrance(CHAR_DATA*, short int)â:
act_move.c:449: warning: converting to âshort intâ from âdoubleâ
act_move.c:453: warning: converting to âshort intâ from âdoubleâ
act_move.c:457: warning: converting to âshort intâ from âdoubleâ
make[1]: *** [o/act_move.o] Error 1
make: *** [all] Error 2

       
Post is unread #7 Mar 27, 2010, 10:15 pm
Go to the top of the page
Go to the bottom of the page

ayuri
Magician
GroupMembers
Posts239
JoinedJun 13, 2008

What distro you trying to build it in and what gcc version?
ayuri
       
Pages:<< prev 1 next >>