Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Yahoo!, Majestic-12, Bing

Members: 0
Guests: 6
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
Evoru (32)
Related Links
» SmaugMuds.org » General » General Discussions » Compiling errors... Please he...
Forum Rules | Mark all | Recent Posts

Compiling errors... Please help the UNIX illiterate!
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jan 4, 2010, 10:43 am
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

It's been driving me crazy. I'm using Cygwin (latest version) and when i attempt to compile SmaugFUSS 1.8, it (for some reason) screws up. It tells me...

act_move.c:604: error: lvalue required as left hand of operant assignment
make[1] *** [act_move.o] Error 1
make[1] Leaving directory '/home/James/smaug1.8/src'
make: *** [all] Error 2


and then it fails out and stops doing anything.

i have NO idea what this means... any UNIX people know how to fix this?

- Silah
       
Post is unread #2 Jan 4, 2010, 10:56 am
Go to the top of the page
Go to the bottom of the page

David Haley
Sorcerer
GroupMembers
Posts903
JoinedJan 29, 2007

I believe that this was (probably) fixed in 1.9; is there a reason why you're using 1.8 and not 1.9?
       
Post is unread #3 Jan 4, 2010, 11:08 am
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

I hadn't looked for it... I'll go get it and see if it helps. I'll repost if it still fails.
       
Post is unread #4 Jan 4, 2010, 12:43 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Actually that error was fixed quite some time back and shouldn't be showing up in 1.8. Are you sure you're not using the Smaug 1.8 that was released by RoD?
       
Post is unread #5 Jan 4, 2010, 3:20 pm
Go to the top of the page
Go to the bottom of the page

Hanaisse
Magician
GroupMembers
Posts196
JoinedNov 25, 2007

Silah said:

..... when i attempt to compile SmaugFUSS 1.8, ...


make[1] Leaving directory '/home/James/smaug1.8/src'



You're not actually using SmaugFUSS, you're using very old Smaug 1.8, based on the name of your directory. If it was FUSS, the directory would say smaugfuss.

Unless you're trying to restart an old mud you had then, as suggested above, your best bet is to download SmaugFUSS 1.9 from this site and there should be no problems getting it to compile cleanly.

       
Post is unread #6 Jan 4, 2010, 4:11 pm
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

Thanks very much you guys. FUSS 1.9 compiled like a charm! Sorry for the n00b-ness... I'm not a UNIX man.
       
Post is unread #7 Jan 4, 2010, 4:48 pm
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

New question; Logged in with FUS 1.9's Admin default, but no commands work :S what the hell?
       
Post is unread #8 Jan 4, 2010, 5:00 pm
Go to the top of the page
Go to the bottom of the page

Zeno
Sorcerer
GroupMembers
Posts723
JoinedMar 5, 2005

Are you using Cygwin? Did you make sure to edit the Makefile properly?
       
Post is unread #9 Jan 4, 2010, 5:02 pm
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

I had to edit the makefile? :S (Yeah, Cygwin)
       
Post is unread #10 Jan 4, 2010, 5:08 pm
Go to the top of the page
Go to the bottom of the page

Zeno
Sorcerer
GroupMembers
Posts723
JoinedMar 5, 2005

There are comments in the Makefile that should say something like "If you are using Cygwin, do this" or "If you are having dynamic command issues, do this".
       
Post is unread #11 Jan 5, 2010, 5:31 am
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

I'm lost... I have no idea which bits of the makefile to edit. I haven't got a clue! Helps!
       
Post is unread #12 Jan 5, 2010, 6:17 am
Go to the top of the page
Go to the bottom of the page

Hanaisse
Magician
GroupMembers
Posts196
JoinedNov 25, 2007

In the makefile, very near the top you'll find,
#Uncomment to compile in Cygwin
#CYGWIN = -DCYGWIN

change it to,
#Uncomment to compile in Cygwin
CYGWIN = -DCYGWIN

Make clean, make, and try again.
       
Post is unread #13 Jan 5, 2010, 10:52 am
Go to the top of the page
Go to the bottom of the page

Silah
Fledgling
GroupMembers
Posts17
JoinedJan 4, 2010

Thankyou guys, you've all been so helpful. Now everything works, I know how to build using SMAUG's internal code. You all rock! I'll be sure to let everyone know how awesome you are!

- Silah
       
Pages:<< prev 1 next >>