Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Majestic-12, Sogou, Yandex

Members: 0
Guests: 6
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » General » Coding » Another problem installing Ov...
Forum Rules | Mark all | Recent Posts

Another problem installing Overland
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Sep 29, 2009, 9:38 pm
Go to the top of the page
Go to the bottom of the page

Lares
Fledgling
GroupMembers
Posts13
JoinedSep 29, 2009

Got all my errors fixed up until the part where I compile the actual Overland.c file. Now, all of a sudden I'm getting all these errors, and this is not the whole list.
The actual error list is about 3 pages long. Can anyone help me?

imc.h:421: error: âFILEâ has not been declared
imc.h:422: error: âFILEâ has not been declared
mud.h:3477: error: expected initializer before â*â token
mud.h:4492: error: âFILEâ was not declared in this scope
mud.h:4492: error: âfpâ was not declared in this scope
mud.h:4493: error: âFILEâ was not declared in this scope
mud.h:4493: error: âfpâ was not declared in this scope
mud.h:4494: error: âFILEâ was not declared in this scope
mud.h:4494: error: âfpâ was not declared in this scope
mud.h:4495: error: âFILEâ has not been declared
mud.h:4498: error: âFILEâ was not declared in this scope
mud.h:4498: error: âfpâ was not declared in this scope
mud.h:4499: error: âFILEâ was not declared in this scope
mud.h:4499: error: âfpâ was not declared in this scope
mud.h:4500: error: âFILEâ was not declared in this scope
mud.h:4500: error: âfpâ was not declared in this scope
mud.h:4501: error: variable or field âfread_to_eolâ declared void
mud.h:4501: error: âFILEâ was not declared in this scope
mud.h:4501: error: âfpâ was not declared in this scope
mud.h:4502: error: âFILEâ was not declared in this scope
mud.h:4502: error: âfpâ was not declared in this scope
mud.h:4503: error: âFILEâ was not declared in this scope
mud.h:4503: error: âfpâ was not declared in this scope
mud.h:4640: error: âFILEâ has not been declared
mud.h:4641: error: âFILEâ has not been declared
mud.h:4659: error: variable or field âfwrite_morphâ declared void
mud.h:4659: error: âFILEâ was not declared in this scope
mud.h:4659: error: âfpâ was not declared in this scope
mud.h:4659: error: expected primary-expression before â*â token
mud.h:4659: error: âmorphâ was not declared in this scope
mud.h:4659: error: initializer expression list treated as compound expression
mud.h:4661: error: âFILEâ was not declared in this scope
mud.h:4661: error: âfpâ was not declared in this scope
mud.h:4693: error: âFILEâ was not declared in this scope
mud.h:4693: error: âfpâ was not declared in this scope
mud.h:4693: error: expected primary-expression before â*â token
       
Post is unread #2 Sep 29, 2009, 9:56 pm
Go to the top of the page
Go to the bottom of the page

Kayle
Off the Edge of the Map
GroupAdministrators
Posts1,195
JoinedMar 21, 2006

up at the top of the file make sure there's an #include <stdio.h>
       
Post is unread #3 Sep 30, 2009, 6:14 pm   Last edited Sep 30, 2009, 9:36 pm by Lares
Go to the top of the page
Go to the bottom of the page

Lares
Fledgling
GroupMembers
Posts13
JoinedSep 29, 2009

Wow, something so simple. Thanks a ton for the help.

New problem. Again, I'm not a programmer, and to the seasoned vet, these may seem easy fixes...but...I appreciate all your help.

Overland being patched into smaugFUSS1.9.

o/build.o: In function `do_redit':
/home/m104bri/wot/dev/src/build.c:5473: undefined reference to `do_at'
o/overland.o: In function `load_mapfile(char*, short)':
/home/m104bri/wot/dev/src/overland.c:1983: undefined reference to `shutdown_mud(char*)'
o/overland.o: In function `do_mreset(char_data*, char*)':
/home/m104bri/wot/dev/src/overland.c:1826: undefined reference to `do_mreset'
/home/m104bri/wot/dev/src/overland.c:1960: undefined reference to `do_mreset'
o/overland.o: In function `do_setexit(char_data*, char*)':
/home/m104bri/wot/dev/src/overland.c:1415: undefined reference to `do_setexit'
/home/m104bri/wot/dev/src/overland.c:1467: undefined reference to `do_setexit'
o/overland.o: In function `do_setmark(char_data*, char*)':
/home/m104bri/wot/dev/src/overland.c:1094: undefined reference to `do_setmark'
o/update.o: In function `char_check()':
/home/m104bri/wot/dev/src/update.c:1573: undefined reference to `map_wander(char_data*, short, short, short, short)'
/home/m104bri/wot/dev/src/update.c:1577: undefined reference to `map_wander(char_data*, short, short, short, short)'
/home/m104bri/wot/dev/src/update.c:1581: undefined reference to `map_wander(char_data*, short, short, short, short)'
/home/m104bri/wot/dev/src/update.c:1585: undefined reference to `map_wander(char_data*, short, short, short, short)'
/home/m104bri/wot/dev/src/update.c:1589: undefined reference to `map_wander(char_data*, short, short, short, short)'
o/update.o:/home/m104bri/wot/dev/src/update.c:1593: more undefined references to `map_wander(char_data*, short, short, short, short)' follow



Thank you in advance for any help you can provide.
       
Post is unread #4 Oct 1, 2009, 8:09 pm
Go to the top of the page
Go to the bottom of the page

Lares
Fledgling
GroupMembers
Posts13
JoinedSep 29, 2009

Fixed my previous problems, please look at this if you get a chance and let me know if you see why it's giving me this error...

overland.c:3459
      int flood;
      flood = get_sectypes( argument );

overland.c:3459: error: invalid conversion from âconst char*â to âchar*â
overland.c:3459: error:   initializing argument 1 of âint get_sectypes(char*)â


Appreciate any help please.
       
Post is unread #5 Oct 1, 2009, 8:54 pm
Go to the top of the page
Go to the bottom of the page

ChrisBailey
Fledgling
GroupMembers
Posts11
JoinedMar 15, 2008

This is a bit off-topic but are you the Lares from Age of the Ancients?
       
Post is unread #6 Oct 1, 2009, 8:55 pm
Go to the top of the page
Go to the bottom of the page

Lares
Fledgling
GroupMembers
Posts13
JoinedSep 29, 2009

I am that Lares. AKA Prophecy from Gates/Chronicles/Temple of the Arcana

And for anyone that looks at this thread. I fixed all my problems so far and overland seems to be working well in Fuss1.9.
       
Pages:<< prev 1 next >>