Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, DotBot

Members: 0
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » General » General Discussions » Possible UTF-8 Errors
Forum Rules | Mark all | Recent Posts

Possible UTF-8 Errors
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Sep 26, 2009, 1:25 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Just as an FYI - if you happen across a post that QSFP reports got an error involving htmlentities and invalid multi-byte sequences, don't bother to report it. Those errors will get emailed to me and I'll fix them as they're found. Search engines seem to be doing a wonderful job of that so far.

This stems from recent action taken to get the forum to properly parse UTF-8 characters. The database and the PHP code both needed a tweak to allow for non-English characters to display properly - most often seen around here with GCC output and funny looking question marks. Those all appear to be gone now but some old posts have junk data in them that wasn't triggering errors before. Likely leftovers from forum software conversions over the years.
       
Post is unread #2 Oct 13, 2009, 2:31 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Apologies for not having mentioned this sooner, but there was a topic about password corruption in the forum that refused to go along with the UTF-8 update and rendered the topic unviewable. It had to be deleted, but like a boob, I got distracted with the post's text sitting in an unsaved window and turned the computer off without saving it. Things have been a bit hectic in the days following that, and I'll have to dig through the DB update to find it, it won't be directly postable because of the UTF-8 issue, but I'll drop a text link in to a raw text file.

Let's just say that certain recent events have given me time to go back and clean up some backlog in various places and get some things taken care of that I've been neglecting. This is one of those things.
       
Pages:<< prev 1 next >>