Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Users Online
CommonCrawl, DotBot

Members: 0
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
477
3,705
19,232
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Error /usr/bin/ld.real
Forum Rules | Mark all | Recent Posts

Error /usr/bin/ld.real
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Aug 19, 2009, 1:38 am
Go to the top of the page
Go to the bottom of the page

manicxellos
Fledgling
GroupMembers
Posts2
JoinedAug 19, 2009

I have been working on getting AFKMud to compile. So far I have been able to get past a few complier errors, like the overland issue with missing libgd. Currently I have the following error.

Building AFKMud....
make -j2 -s afkmud
/usr/bin/ld.real: cannot find -lgd
collect2: ld returned 1 exit status
make[1]: *** [afkmud] Error 1
make: *** [all] Error 2

I would appreciate any help that can be offered. I feel that I am close to getting it running, but this error has baffled me.
       
Post is unread #2 Aug 19, 2009, 8:23 am
Go to the top of the page
Go to the bottom of the page

David Haley
Sorcerer
GroupMembers
Posts903
JoinedJan 29, 2007

So far I have been able to get past a few complier errors, like the overland issue with missing libgd. Currently I have the following error.

How did you get past the libgd error? The error you're seeing (cannot find -lgd) is the linker telling you that it can't find the gd library. Did you install libgd using your package manager or on your own? If you did it on your own, I would try doing it with the distribution package manager.
       
Post is unread #3 Aug 19, 2009, 2:26 pm
Go to the top of the page
Go to the bottom of the page

manicxellos
Fledgling
GroupMembers
Posts2
JoinedAug 19, 2009

I manually installed it, because when I used the package manager it kept throwing an error stating that gd.h was not found. I'll go back and try again with the package manager. Thanks for the help in direction I missed the -lgd correlation.
       
Post is unread #4 Aug 19, 2009, 3:13 pm
Go to the top of the page
Go to the bottom of the page

David Haley
Sorcerer
GroupMembers
Posts903
JoinedJan 29, 2007

Which Linux distribution are you using? You usually have to install the -dev version, like libgd-dev or something like that.
       
Pages:<< prev 1 next >>