Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Bing, Yahoo!

Members: 0
Guests: 11
Stats
Files
Topics
Posts
Members
Newest Member
477
3,705
19,232
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SWR FUSS » possible bug with the CHECK_L...
Forum Rules | Mark all | Recent Posts

possible bug with the CHECK_LINKS macro
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jul 13, 2009, 8:38 am   Last edited Jul 13, 2009, 11:41 am by Andril
Go to the top of the page
Go to the bottom of the page

Andril
Magician
GroupMembers
Posts147
JoinedJun 9, 2009

Or maybe with the INSERT macro, though I don't think this is the case.

Anyways, I'm trying to use INSERT to, well, insert something in front of something else. Afterwards I'm calling CHECK_LINKS just to make sure everything is still working like it should be and the mud hangs. Here's what the log file shows for the last session when this happened.
Mon Jul 13 08:26:18 2009 :: [*****] BUG: CHECK_LINKS(ship->first_module): 0x91d3088:->prev != 0x91cf000.  Fixing.
Mon Jul 13 08:26:18 2009 :: [*****] BUG: CHECK_LINKS(ship->first_module): 0x91d3088:->prev != 0x91d3088.  Fixing.


Now, looking at the CHECK_LINKS macro, ship->first_module(*ptr)->prev is getting checked against *pptr, which should be NULL. This is, apparently, not the case. It also appears to be stuck in an infinite loop, which is why I believe the mud is hanging, because, as you can see, *pptr is changing, but it's not changing *ptr, which looks to be stuck on ship->first_module.

Then again, it only happens after using INSERT, so maybe it is the other way around?
       
Pages:<< prev 1 next >>