Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Bing, DotBot

Members: 0
Guests: 4
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
614
BenitoVirg
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SWR FUSS » Bug in mppurge
Forum Rules | Mark all | Recent Posts

Bug in mppurge
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Nov 13, 2008, 5:13 am
Go to the top of the page
Go to the bottom of the page

Samsa
Fledgling
GroupMembers
Posts15
JoinedAug 29, 2008

This affects the last version of swr and probably affects smaug also.

When using mppurge to purge a single object, all identical objects are purged, not only one as it is expected.
To fix this, at mud_comm.c, look for do_mppurge and change:

if ( (obj = get_obj_here( ch, arg )) != NULL )
    extract_obj( obj );
else
    progbug( "Mppurge - Bad argument", ch );
return;


to

if ( (obj = get_obj_here( ch, arg )) != NULL ) {
	separate_obj( obj );
	extract_obj( obj );
} else
	progbug( "Mppurge - Bad argument", ch );
return;


       
Post is unread #2 Nov 17, 2008, 6:11 am
Go to the top of the page
Go to the bottom of the page

Keberus
Conjurer
GroupFUSS Project Team
Posts341
JoinedJun 4, 2005

Nice Catch.

-->KeB
       
Pages:<< prev 1 next >>