Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
 parse description bug
Yesterday, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex

Members: 0
Guests: 12
Stats
Files
Topics
Posts
Members
Newest Member
477
3,706
19,240
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SWR FUSS » Reset System Fix ( Planets an...
Forum Rules | Mark all | Recent Posts

Reset System Fix ( Planets and Population )
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Aug 11, 2008, 9:45 pm
Go to the top of the page
Go to the bottom of the page

Amras
Fledgling
GroupMembers
Posts18
JoinedAug 11, 2008

With the new reset system fix applied to the SWR codebase, the planets no longer get their population set. Originally in SWR, the process of adding population the planet looked like this,

      if ( mob->vip_flags != 0 && pArea->planet )
            pArea->planet->population++;


But that no longer works, how would you go about making the population for planets be updated properly with the new reset system?
       
Pages:<< prev 1 next >>