Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
Bug in get_exp_worth( )
Oct 10, 2017, 1:26 am
By GatewaySysop
Bug in do_drag( )
Oct 8, 2017, 12:40 am
By GatewaySysop
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Beastmaster 6D sound files
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Bing, Google, Yahoo!, Majestic-12

Members: 0
Guests: 5
Stats
Files
Topics
Posts
Members
Newest Member
476
3,704
19,231
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SmaugFUSS » Smaug Color/Copyover Problem!
Forum Rules | Mark all | Recent Posts

Smaug Color/Copyover Problem!
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Apr 14, 2003, 8:43 pm
Go to the top of the page
Go to the bottom of the page

Saken
New Member
GroupMembers
Posts3
JoinedApr 14, 2003

Hey all quick question for ya.
I'm not a snippet buster at all, but I have installed a few
and modified them some what. But here is what one of my coders did
on my test port, and I can't seem to figure them out.

1) Smaug 1.4 with Lopes Color codes/ Copyover. Copyover worked great. He then installed the color login snip that is floating around here (the one ported to smaug from merc). Color code works great (except for the lag alarm clock that goes off) except now when I do a copyover, the prompt turns to grey. When I type who, everything is grey. I still have the ANSI flag on, but everything is grey. Except practice, score, says, tells etc etc are all fine. But the prompt and WHO are always grey. When i d/c and reconnect, all the colors are fine. Any solutions on this?

2) He added Lrd's Newarena snip (newarena.c, ported from RoM's arena made by kevin H aka Goon: Kevin, where are ya? Its Hansth from PR man!) Sorry I use to code with Kevin but we lost touch like 8 years ago Anyways, works fine, everything with it does actually, except it doesn't regonize the && !IN_ARENA checks in the do_murder function. It should cancel the check on age (<1 but it doesn't. I had to change the <18 for age to <10. Not a big deal. But it does become a big deal when someone dies and their corpse gets left behind in the arena. Any ideas?

Anyways, thats it for now. Any ideas or suggestions would be muchly appreciated.

Good day :P

-Saken
       
Post is unread #2 Apr 15, 2003, 6:42 am
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

When you say Lope's, are you SURE it's actually Lope's color system? Ported from RoM and used in your Smaug? That being the case I'd need to see that code before being able to make a determination of how it's affecting copyover because it should not be. The custom ANSI code I have floating around works perfectly with the Hotboot code I also have floating around, and should work just fine with any version of Smaug copyover. But if you have something different it would need to be examined to see why it's not saving the color info.

As for the arena snippet, I've never messed with it. Someone else will need to field that one :)
       
Post is unread #3 Apr 15, 2003, 7:41 am
Go to the top of the page
Go to the bottom of the page

Saken
New Member
GroupMembers
Posts3
JoinedApr 14, 2003

It might be yours. I wrote myown a while back so I'm not all familar with yours. But he is using a colorize.c and types help pcolors so *shrug*

But it all started when he put that send_to_desc_color function at the bottom of comm.c, underneath do_copyover_recover

:P I'll post that code when I get home

-Saken
       
Pages:<< prev 1 next >>