Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
6Dragons 4.4
Author: Vladaar
Submitted by: Vladaar
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yahoo!, Google

Members: 0
Guests: 8
Stats
Files
Topics
Posts
Members
Newest Member
479
3,708
19,242
614
BenitoVirg
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » BFD code - affecting AFKMud
Forum Rules | Mark all | Recent Posts

BFD code - affecting AFKMud
< Newer Topic :: Older Topic > Version 1.25 and lower affected!

Pages:<< prev 1 next >>
Post is unread #1 Mar 22, 2003, 4:41 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Heads up to those of you running AFKMud from version 1.25 and lower. It's come to my attention that the BFD code installed to the base will no longer function after doing one of the recent updates to the binutils module in Redhat 8.x. Unfortunately in this case the update was for security reasons and anyone using binutils would be wise to upgrade. This will of course mean that if the server you host your mud on runs Redhat and has made this update ( not yet available via up2date ) then you'll not be able to compile the code since the critical functions to operate the BFD support are no longer available for some reason.

Plans are to make the dlsym support available within the next few days. This won't be in patch form, but should be clear enough to follow to replace BFD and not do any harm to an existing base.

Be aware that this will also affect anyone using the BFD snippet and anyone who may still be using the old FixedSmaug package I used to maintain, as well as the Altanos codebase.
       
Post is unread #2 Mar 25, 2003, 10:29 am
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Good news, at least for those using AFKMud 1.25

A patch to convert the codebase over to dlsym has been created. It works on a stock 1.25, but I cannot make any promises as to what else it will work with. I'd not suggest even trying on anything outside the AFK family since the results could be.... well.... BAD. Patch is available from the code page.

FixedSmaug users and Altanos users are on their own though. I don't provide support of any kind for those bases and haven't for quite some time now. You can feel free to pull apart the patch and do the work yourself, though I won't be able to help if you break something.
       
Pages:<< prev 1 next >>