Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
Bug in will_fall( )
Oct 23, 2017, 1:35 am
By GatewaySysop
Bug in do_zap( ), do_brandish( )
Oct 18, 2017, 1:52 pm
By GatewaySysop
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Memwatch
Author: Johan Lindh
Submitted by: Vladaar
Users Online
CommonCrawl, Yahoo!, Bing, DotBot

Members: 0
Guests: 10
Stats
Files
Topics
Posts
Members
Newest Member
477
3,706
19,240
608
LAntorcha
Today's Birthdays
There are no member birthdays today.
Related Links
» SmaugMuds.org » Codebases » SWR FUSS » Mob AC not set properly
Forum Rules | Mark all | Recent Posts

Mob AC not set properly
< Newer Topic :: Older Topic > create_mobile error

Pages:<< prev 1 next >>
Post is unread #1 Aug 6, 2005, 8:11 pm   Last edited Aug 9, 2005, 10:12 am by Greven
Go to the top of the page
Go to the bottom of the page

Greven
Magician
GroupMembers
Posts204
JoinedMar 5, 2005

When a mob is instantiated with create_mobile(), the armor is not being set properly
   if( !pMobIndex->ac )
      mob->armor = pMobIndex->ac;
   else
      mob->armor = 100 - mob->top_level * 2.5;
Should be:
   if( pMobIndex->ac )
      mob->armor = pMobIndex->ac;
   else
      mob->armor = 100 - mob->top_level * 2.5;
Other wise you access a NULL field, or they never have the properly set AC. This does not apply to SMAUG, as it has this comment in the code, which I found when I went to see if it applied elsewhere, may apply to FotE, no idea:

/*
* Bug fix from mailing list by stu (sprice@ihug.co.nz)
* was: if ( !pMobIndex->ac )
*/
       
Pages:<< prev 1 next >>