Login
User Name:

Password:



Register
Forgot your password?
Vote for Us!
auth_update crash
Dec 23, 2017, 10:15 pm
By Remcon
check_tumble
Dec 18, 2017, 7:21 pm
By Remcon
parse description bug
Dec 15, 2017, 10:08 pm
By Remcon
Couple bugs
Dec 12, 2017, 5:42 pm
By Remcon
Bug in disarm( )
Nov 12, 2017, 6:54 pm
By GatewaySysop
LoP 1.46
Author: Remcon
Submitted by: Remcon
LOP 1.45
Author: Remcon
Submitted by: Remcon
LOP Heroes Edition
Author: Vladaar
Submitted by: Vladaar
Heroes sound extras
Author: Vladaar
Submitted by: Vladaar
6Dragons 4.3
Author: Vladaar
Submitted by: Vladaar
Users Online
CommonCrawl, Yandex, Yahoo!, Bing

Members: 0
Guests: 12
Stats
Files
Topics
Posts
Members
Newest Member
478
3,708
19,242
612
Jacki72H
Today's Birthdays
Evoru (32)
Related Links
» SmaugMuds.org » Codebases » AFKMud Support & Development » Problem with overland...
Forum Rules | Mark all | Recent Posts

Problem with overland...
< Newer Topic :: Older Topic >

Pages:<< prev 1 next >>
Post is unread #1 Jan 3, 2007, 4:36 am
Go to the top of the page
Go to the bottom of the page

N_Yo_FACE

GroupMembers
Posts15
JoinedJan 8, 2003

I tried entering a "goto map" command. It gave me "Woops. Something is majorly wrong here - inform the immortals." as a response. Below is the output in the server console:

Wed Jan 3, 2007 4:27:44 AM PST :: [*****] BUG: enter_map: Overland map room is missing!
Wed Jan 3, 2007 4:27:44 AM PST :: Obtained 9 stack frames.
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(_Z3bugPKcz+0x220) [0x5a31f0]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(_Z9enter_mapP9char_dataP9exit_dataiii+0xe4) [0x65a7c8]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(do_goto+0x14e) [0x54915e]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(_Z9interpretP9char_dataPc+0x141d) [0x599845]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(_Z13process_inputv+0x537) [0x58d07b]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(_Z9game_loopv+0x60) [0x58d64a]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(main+0x23c) [0x58e19a]
Wed Jan 3, 2007 4:27:44 AM PST :: /lib64/tls/libc.so.6(__libc_start_main+0xda) [0x2aaaab3ac5aa]
Wed Jan 3, 2007 4:27:44 AM PST :: ./afkmud(__gxx_personality_v0+0x102) [0x48309a]

Note, this is a fresh install, no changes to source code (other than changing a "unsigned int" in descriptor.cpp to "size_t" due to AMD64 issues).
       
Post is unread #2 Jan 3, 2007, 6:19 pm
Go to the top of the page
Go to the bottom of the page

kiasyn
Magician
GroupMembers
Posts121
JoinedJun 30, 2006

you're missing an area.
       
Post is unread #3 Jan 3, 2007, 6:34 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Oops. No. The area.lst file is wrong. It needs to be changed to contain the following:

void.are
entry.are
astral.are
one.are
immtrain.are
$

       
Post is unread #4 Jan 3, 2007, 8:01 pm
Go to the top of the page
Go to the bottom of the page

kiasyn
Magician
GroupMembers
Posts121
JoinedJun 30, 2006

Same thing :p
       
Post is unread #5 Jan 3, 2007, 8:26 pm
Go to the top of the page
Go to the bottom of the page

Samson
Black Hand
GroupAdministrators
Posts3,639
JoinedJan 1, 2002

Not the same thing. He wasn't missing an area. The area.lst file was listing areas that don't exist in the package. Vastly different.
       
Pages:<< prev 1 next >>